<!DOCTYPE html><html lang="en-US"><head><style id="rocket-critical-css">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</style><meta charset="UTF-8"><meta name="viewport" content="width=device-width,initial-scale=1.0"><link rel="pingback" href="https://sunriseread.com/xmlrpc.php"><title>‘Peasant’ Rihanna bumps into ‘legend’ Paul McCartney on flight - Sunriseread</title><link rel="preload" href="https://sunriseread.com/wp-content/cache/min/1/8bc1eee8698f291a7c408e5d6b7a0be9.css" as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" /><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="https://sunriseread.com/peasant-rihanna-bumps-into-legend-paul-mccartney-on-flight/21346/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="‘Peasant’ Rihanna bumps into ‘legend’ Paul McCartney on flight - Sunriseread" /><meta property="og:description" content="Rihanna information operating into Paul McCartney on her flight.Instagram After Rihanna’s fast journey to Italy, the songstress was stunned to seek out icon and former collaborator Paul McCartney on her flight. “I’m about to place you on blast, Mr. McCartney. How are you on my flight?” Riri, 31, requested via giggles within the Instagram video, &hellip;" /><meta property="og:url" content="https://sunriseread.com/peasant-rihanna-bumps-into-legend-paul-mccartney-on-flight/21346/" /><meta property="og:site_name" content="Sunriseread" /><meta property="article:section" content="General News" /><meta property="article:published_time" content="2020-01-03T00:45:04+00:00" /><meta property="article:modified_time" content="2020-01-03T00:45:05+00:00" /><meta property="og:updated_time" content="2020-01-03T00:45:05+00:00" /><meta property="og:image" content="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?fit=1200%2C791&#038;ssl=1" /><meta property="og:image:secure_url" content="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?fit=1200%2C791&#038;ssl=1" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="791" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Rihanna information operating into Paul McCartney on her flight.Instagram After Rihanna’s fast journey to Italy, the songstress was stunned to seek out icon and former collaborator Paul McCartney on her flight. “I’m about to place you on blast, Mr. McCartney. How are you on my flight?” Riri, 31, requested via giggles within the Instagram video, [&hellip;]" /><meta name="twitter:title" content="‘Peasant’ Rihanna bumps into ‘legend’ Paul McCartney on flight - Sunriseread" /><meta name="twitter:image" content="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?fit=1200%2C791&#038;ssl=1" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://sunriseread.com/#website","url":"https://sunriseread.com/","name":"Sunriseread","description":"Latest News Bulletins!","potentialAction":{"@type":"SearchAction","target":"https://sunriseread.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://sunriseread.com/peasant-rihanna-bumps-into-legend-paul-mccartney-on-flight/21346/#primaryimage","url":"https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?fit=1200%2C791&ssl=1","width":1200,"height":791},{"@type":"WebPage","@id":"https://sunriseread.com/peasant-rihanna-bumps-into-legend-paul-mccartney-on-flight/21346/#webpage","url":"https://sunriseread.com/peasant-rihanna-bumps-into-legend-paul-mccartney-on-flight/21346/","inLanguage":"en-US","name":"\u2018Peasant\u2019 Rihanna bumps into \u2018legend\u2019 Paul McCartney on flight - Sunriseread","isPartOf":{"@id":"https://sunriseread.com/#website"},"primaryImageOfPage":{"@id":"https://sunriseread.com/peasant-rihanna-bumps-into-legend-paul-mccartney-on-flight/21346/#primaryimage"},"datePublished":"2020-01-03T00:45:04+00:00","dateModified":"2020-01-03T00:45:05+00:00","author":{"@id":"https://sunriseread.com/#/schema/person/0172aafc3fb60516b395503d00fb9d5f"}},{"@type":["Person"],"@id":"https://sunriseread.com/#/schema/person/0172aafc3fb60516b395503d00fb9d5f","name":"Sam Conley","image":{"@type":"ImageObject","@id":"https://sunriseread.com/#authorlogo","url":"https://secure.gravatar.com/avatar/1477b2ca4dfdfa3258752a6afb38c412?s=96&d=mm&r=g","caption":"Sam Conley"},"description":"Sam Conley is new to online journalism but she is keen to learn. She is an MBA from a reputed university. She brings together relevant news pieces from various industries. She loves to share quick news updates. She is always in search of interesting news so that she can share them as well to Sunriseread's readers who could enjoy them with their morning coffee.","sameAs":[]}]}</script> <link rel="amphtml" href="https://sunriseread.com/peasant-rihanna-bumps-into-legend-paul-mccartney-on-flight/21346/amp/" /><meta name="generator" content="AMP for WP 1.0.6"/><link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Sunriseread &raquo; Feed" href="https://sunriseread.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Sunriseread &raquo; Comments Feed" href="https://sunriseread.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Sunriseread &raquo; ‘Peasant’ Rihanna bumps into ‘legend’ Paul McCartney on flight Comments Feed" href="https://sunriseread.com/peasant-rihanna-bumps-into-legend-paul-mccartney-on-flight/21346/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='preload' id='wp-block-library-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/style.min.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='herald-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%7CLato%3A400%2C700&#038;subset=latin%2Clatin-ext&#038;ver=1.5.2' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><style id='herald-main-inline-css' type='text/css'>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</style><style id='rocket-lazyload-inline-css' type='text/css'>.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;background:#000;margin:5px}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://sunriseread.com/wp-content/plugins/wp-rocket/inc/front/img/play.png) no-repeat;cursor:pointer}</style><link rel='preload' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.0/css/jetpack.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='https://api.w.org/' href='https://sunriseread.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://sunriseread.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://sunriseread.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.3.2" /><link rel='shortlink' href='https://sunriseread.com/?p=21346' /><link rel='dns-prefetch' href='//c0.wp.com'/><link rel='dns-prefetch' href='//i0.wp.com'/><link rel='dns-prefetch' href='//i1.wp.com'/><link rel='dns-prefetch' href='//i2.wp.com'/><link rel='dns-prefetch' href='//v0.wordpress.com'/><style type='text/css'>img#wpstats{display:none}</style> <script data-no-minify="1" async src="https://sunriseread.com/wp-content/cache/busting/1/gtm-local.js"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-145469000-1');</script> <style type="text/css" id="wp-custom-css">.header-middle{background-color:white}.header-middle a{color:#0288d1}.entry-content a{border-bottom:1px solid #ddd}.herald-mod-head:after,.herald-mod-title .herald-color,.widget-title:after,.widget-title span{background-color:#0d0c65}</style><meta name="indi-verification" content="f3502df6" /><meta name="msvalidate.01" content="CD12270AC6CD594A97CB48A09AF3F495" /><meta name="verifyownership"  content="1bfb7797abd1dbf6eed5a686ae2ac5b9"/><meta name="google-site-verification" content="zSIbkPscsVAoHQBO5tyuKsE9soEqyiDpL-ezuFbJDEY" /> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-9781525442333142",
          enable_page_level_ads: true
     });</script> </head><body class="post-template-default single single-post postid-21346 single-format-standard unknown herald-boxed"><div id="fb-root"></div><header id="header" class="herald-site-header"><div class="header-top hidden-xs hidden-sm"><div class="container"><div class="row"><div class="col-lg-12"><div class="hel-l"><nav class="secondary-navigation herald-menu"><ul id="menu-page-menu" class="menu"><li id="menu-item-131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-131"><a href="https://sunriseread.com/">Home</a></li><li id="menu-item-157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-157"><a href="https://sunriseread.com/about/">About</a></li><li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://sunriseread.com/team/">Team</a></li><li id="menu-item-156" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://sunriseread.com/contact/">Contact</a></li><li id="menu-item-154" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://sunriseread.com/cookie-policy/">Cookie Policy</a></li><li id="menu-item-159" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159"><a href="https://sunriseread.com/terms-of-use/">Terms of Use</a></li><li id="menu-item-160" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-160"><a href="https://sunriseread.com/privacy-policy/">Privacy Policy</a></li></ul></nav></div><div class="hel-r"> <span class="herald-calendar"><i class="fa fa-calendar"></i>2nd January 2020</span></div></div></div></div></div><div class="header-middle herald-header-wraper hidden-xs hidden-sm"><div class="container"><div class="row"><div class="col-lg-12 hel-el"><div class="hel-l herald-go-hor"><div class="site-branding"> <span class="site-title h1"><a href="https://sunriseread.com/" rel="home"><img class="herald-logo" src="https://sunriseread.com/wp-content/uploads/2019/05/sunriseread.png" alt="Sunriseread" ></a></span></div></div><div class="hel-r herald-go-hor"></div></div></div></div></div><div class="header-bottom herald-header-wraper hidden-sm hidden-xs"><div class="container"><div class="row"><div class="col-lg-12 hel-el"><div class="hel-l"><nav class="main-navigation herald-menu"><ul id="menu-cat-menu" class="menu"><li id="menu-item-135" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-135"><a href="https://sunriseread.com">Home</a><li id="menu-item-132" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-132"><a href="https://sunriseread.com/category/business/">Business</a><li id="menu-item-133" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-133"><a href="https://sunriseread.com/category/general-news/">General News</a><li id="menu-item-134" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-134"><a href="https://sunriseread.com/category/technology/">Technology</a></ul></nav><div class="herald-menu-popup-search"> <span class="fa fa-search"></span><div class="herald-in-popup"><form class="herald-search-form" action="https://sunriseread.com/" method="get"> <input name="s" class="herald-search-input" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="herald-search-submit"></button></form></div></div></div><div class="hel-r"></div></div></div></div></div><div class="header-trending hidden-xs hidden-sm"><div class="container"><div class="row"><div class="col-lg-12 col-md-12"><div class="row"><div class="col-lg-2 col-md-2"><div class="herald-post-thumbnail"> <a href="https://sunriseread.com/peasant-rihanna-bumps-into-legend-paul-mccartney-on-flight/21346/" title="‘Peasant’ Rihanna bumps into ‘legend’ Paul McCartney on flight"><img width="150" height="150" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-srcset="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" /><noscript><img width="150" height="150" src="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" sizes="(max-width: 150px) 100vw, 150px" /></noscript></a></div><h4 class="h6"><a href="https://sunriseread.com/peasant-rihanna-bumps-into-legend-paul-mccartney-on-flight/21346/">‘Peasant’ Rihanna bumps into ‘legend’ Paul McCartney on flight</a></h4></div><div class="col-lg-2 col-md-2"><div class="herald-post-thumbnail"> <a href="https://sunriseread.com/what-to-watch-chance-the-rapper-on-snl-christmas-movies-and-more/21343/" title="What to Watch: Chance the Rapper on SNL, Christmas (!?) Movies and More"><img width="150" height="150" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/snl-chance-the-rapper-.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-srcset="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/snl-chance-the-rapper-.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/snl-chance-the-rapper-.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/snl-chance-the-rapper-.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" /><noscript><img width="150" height="150" src="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/snl-chance-the-rapper-.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/snl-chance-the-rapper-.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/snl-chance-the-rapper-.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/snl-chance-the-rapper-.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" sizes="(max-width: 150px) 100vw, 150px" /></noscript></a></div><h4 class="h6"><a href="https://sunriseread.com/what-to-watch-chance-the-rapper-on-snl-christmas-movies-and-more/21343/">What to Watch: Chance the Rapper on SNL, Christmas (!?) Movies and More</a></h4></div><div class="col-lg-2 col-md-2"><div class="herald-post-thumbnail"> <a href="https://sunriseread.com/link-tank-the-wildest-space-discoveries-of-2019/21340/" title="Link Tank: The Wildest Space Discoveries of 2019"><img width="150" height="150" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/nasa-16.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-srcset="https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/nasa-16.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/nasa-16.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/nasa-16.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" /><noscript><img width="150" height="150" src="https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/nasa-16.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/nasa-16.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/nasa-16.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/nasa-16.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" sizes="(max-width: 150px) 100vw, 150px" /></noscript></a></div><h4 class="h6"><a href="https://sunriseread.com/link-tank-the-wildest-space-discoveries-of-2019/21340/">Link Tank: The Wildest Space Discoveries of 2019</a></h4></div><div class="col-lg-2 col-md-2"><div class="herald-post-thumbnail"> <a href="https://sunriseread.com/new-hellraiser-trilogy-is-coming-in-2020-heres-everything-we-know/21337/" title="New Hellraiser Trilogy Is Coming In 2020! Here’s Everything We Know"><img width="150" height="150" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://i1.wp.com/sunriseread.com/wp-content/uploads/2020/01/Pinhead-Hellraiser-Doug-Bradley.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-srcset="https://i1.wp.com/sunriseread.com/wp-content/uploads/2020/01/Pinhead-Hellraiser-Doug-Bradley.jpg?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/sunriseread.com/wp-content/uploads/2020/01/Pinhead-Hellraiser-Doug-Bradley.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i1.wp.com/sunriseread.com/wp-content/uploads/2020/01/Pinhead-Hellraiser-Doug-Bradley.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" /><noscript><img width="150" height="150" src="https://i1.wp.com/sunriseread.com/wp-content/uploads/2020/01/Pinhead-Hellraiser-Doug-Bradley.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://i1.wp.com/sunriseread.com/wp-content/uploads/2020/01/Pinhead-Hellraiser-Doug-Bradley.jpg?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/sunriseread.com/wp-content/uploads/2020/01/Pinhead-Hellraiser-Doug-Bradley.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i1.wp.com/sunriseread.com/wp-content/uploads/2020/01/Pinhead-Hellraiser-Doug-Bradley.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" sizes="(max-width: 150px) 100vw, 150px" /></noscript></a></div><h4 class="h6"><a href="https://sunriseread.com/new-hellraiser-trilogy-is-coming-in-2020-heres-everything-we-know/21337/">New Hellraiser Trilogy Is Coming In 2020! Here’s Everything We Know</a></h4></div><div class="col-lg-2 col-md-2"><div class="herald-post-thumbnail"> <a href="https://sunriseread.com/meghan-markle-and-prince-harry-archies-character-is-already-taking-form/21334/" title="Meghan Markle and Prince Harry: Archie’s character is already taking form!"><img width="150" height="150" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-srcset="https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" /><noscript><img width="150" height="150" src="https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" sizes="(max-width: 150px) 100vw, 150px" /></noscript></a></div><h4 class="h6"><a href="https://sunriseread.com/meghan-markle-and-prince-harry-archies-character-is-already-taking-form/21334/">Meghan Markle and Prince Harry: Archie’s character is already taking form!</a></h4></div><div class="col-lg-2 col-md-2"><div class="herald-post-thumbnail"> <a href="https://sunriseread.com/performer-of-the-week-lizzy-caplan/21331/" title="Performer of the Week: Lizzy Caplan"><img width="150" height="150" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://i1.wp.com/sunriseread.com/wp-content/uploads/2020/01/castle-rock-lizzy-caplan.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-srcset="https://i1.wp.com/sunriseread.com/wp-content/uploads/2020/01/castle-rock-lizzy-caplan.jpg?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/sunriseread.com/wp-content/uploads/2020/01/castle-rock-lizzy-caplan.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i1.wp.com/sunriseread.com/wp-content/uploads/2020/01/castle-rock-lizzy-caplan.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" /><noscript><img width="150" height="150" src="https://i1.wp.com/sunriseread.com/wp-content/uploads/2020/01/castle-rock-lizzy-caplan.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://i1.wp.com/sunriseread.com/wp-content/uploads/2020/01/castle-rock-lizzy-caplan.jpg?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/sunriseread.com/wp-content/uploads/2020/01/castle-rock-lizzy-caplan.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i1.wp.com/sunriseread.com/wp-content/uploads/2020/01/castle-rock-lizzy-caplan.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" sizes="(max-width: 150px) 100vw, 150px" /></noscript></a></div><h4 class="h6"><a href="https://sunriseread.com/performer-of-the-week-lizzy-caplan/21331/">Performer of the Week: Lizzy Caplan</a></h4></div></div></div></div></div></div></header><div id="sticky-header" class="herald-header-sticky herald-header-wraper herald-slide hidden-xs hidden-sm"><div class="container"><div class="row"><div class="col-lg-12 hel-el"><div class="hel-l herald-go-hor"><div class="site-branding mini"> <span class="site-title h1"><a href="https://sunriseread.com/" rel="home"><img class="herald-logo-mini" src="https://sunriseread.com/wp-content/uploads/2019/05/sunriseread-small.png" alt="Sunriseread" ></a></span></div></div><div class="hel-r herald-go-hor"><nav class="main-navigation herald-menu"><ul id="menu-cat-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-135"><a href="https://sunriseread.com">Home</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-132"><a href="https://sunriseread.com/category/business/">Business</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-133"><a href="https://sunriseread.com/category/general-news/">General News</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-134"><a href="https://sunriseread.com/category/technology/">Technology</a></ul></nav></div></div></div></div></div><div id="herald-responsive-header" class="herald-responsive-header herald-slide hidden-lg hidden-md"><div class="container"><div class="herald-nav-toggle"><i class="fa fa-bars"></i></div><div class="site-branding mini"> <span class="site-title h1"><a href="https://sunriseread.com/" rel="home"><img class="herald-logo-mini" src="https://sunriseread.com/wp-content/uploads/2019/05/sunriseread-small.png" alt="Sunriseread" ></a></span></div><div class="herald-menu-popup-search"> <span class="fa fa-search"></span><div class="herald-in-popup"><form class="herald-search-form" action="https://sunriseread.com/" method="get"> <input name="s" class="herald-search-input" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="herald-search-submit"></button></form></div></div></div></div><div class="herald-mobile-nav herald-slide hidden-lg hidden-md"><ul id="menu-cat-menu-2" class="herald-mob-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-135"><a href="https://sunriseread.com">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-132"><a href="https://sunriseread.com/category/business/">Business</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-133"><a href="https://sunriseread.com/category/general-news/">General News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-134"><a href="https://sunriseread.com/category/technology/">Technology</a></li></ul></div><div class="herald-ad herald-slide herald-below-header"><center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-9781525442333142"
data-ad-slot="7439825999"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></center></div><div id="content" class="herald-site-content herald-slide"><div class="herald-section container "><article id="post-21346" class="herald-single post-21346 post type-post status-publish format-standard has-post-thumbnail hentry category-general-news"><div class="row"><div class="col-lg-9 col-md-9 col-mod-single col-mod-main"><header class="entry-header"> <span class="meta-category"><a href="https://sunriseread.com/category/general-news/" class="herald-cat-3">General News</a></span><h1 class="entry-title h1">‘Peasant’ Rihanna bumps into ‘legend’ Paul McCartney on flight</h1><div class="entry-meta entry-meta-single"><div class="meta-item herald-date"><span class="updated">2nd January 2020</span></div><div class="meta-item herald-rtime">1 Min Read</div></div></header><div class="herald-post-thumbnail herald-post-thumbnail-single"> <span><img width="990" height="653" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?fit=990%2C653&amp;ssl=1" class="attachment-herald-lay-single size-herald-lay-single wp-post-image" alt="" data-lazy-srcset="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?w=1200&amp;ssl=1 1200w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?resize=300%2C198&amp;ssl=1 300w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?resize=1024%2C675&amp;ssl=1 1024w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?resize=768%2C506&amp;ssl=1 768w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?resize=130%2C86&amp;ssl=1 130w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?resize=187%2C124&amp;ssl=1 187w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?resize=990%2C653&amp;ssl=1 990w" data-lazy-sizes="(max-width: 990px) 100vw, 990px" /><noscript><img width="990" height="653" src="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?fit=990%2C653&amp;ssl=1" class="attachment-herald-lay-single size-herald-lay-single wp-post-image" alt="" srcset="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?w=1200&amp;ssl=1 1200w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?resize=300%2C198&amp;ssl=1 300w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?resize=1024%2C675&amp;ssl=1 1024w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?resize=768%2C506&amp;ssl=1 768w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?resize=130%2C86&amp;ssl=1 130w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?resize=187%2C124&amp;ssl=1 187w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/rihanna-paul-mccartney.jpg?resize=990%2C653&amp;ssl=1 990w" sizes="(max-width: 990px) 100vw, 990px" /></noscript></span></div><div class="row"><div class="col-lg-2 col-md-2 col-sm-2 hidden-xs herald-left"><div class="entry-meta-wrapper"><div class="entry-meta-author"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://secure.gravatar.com/avatar/1477b2ca4dfdfa3258752a6afb38c412?s=112&#038;d=mm&#038;r=g" width="112" height="112" alt="Avatar" class="avatar avatar-112 wp-user-avatar wp-user-avatar-112 photo avatar-default" /><noscript><img src="https://secure.gravatar.com/avatar/1477b2ca4dfdfa3258752a6afb38c412?s=112&#038;d=mm&#038;r=g" width="112" height="112" alt="Avatar" class="avatar avatar-112 wp-user-avatar wp-user-avatar-112 photo avatar-default" /></noscript> <a class="herald-author-name" href="https://sunriseread.com/author/samantha/">Sam Conley</a></div><div class="entry-meta entry-meta-single"><div class="meta-item herald-comments"><a href="https://sunriseread.com/peasant-rihanna-bumps-into-legend-paul-mccartney-on-flight/21346/#respond">Add Comment</a></div></div><ul class="herald-share"> <span class="herald-share-meta"><i class="fa fa-share-alt"></i>Share This!</span><div class="meta-share-wrapper"><li class="facebook"> <a href="javascript:void(0);" data-url="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fsunriseread.com%2Fpeasant-rihanna-bumps-into-legend-paul-mccartney-on-flight%2F21346%2F&amp;t=%E2%80%98Peasant%E2%80%99+Rihanna+bumps+into+%E2%80%98legend%E2%80%99+Paul+McCartney+on+flight"><i class="fa fa-facebook"></i><span>Facebook</span></a></li><li class="twitter"> <a href="javascript:void(0);" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fsunriseread.com%2Fpeasant-rihanna-bumps-into-legend-paul-mccartney-on-flight%2F21346%2F&amp;text=%E2%80%98Peasant%E2%80%99+Rihanna+bumps+into+%E2%80%98legend%E2%80%99+Paul+McCartney+on+flight"><i class="fa fa-twitter"></i><span>Twitter</span></a></li><li class="gplus"> <a href="javascript:void(0);" data-url="https://plus.google.com/share?url=https%3A%2F%2Fsunriseread.com%2Fpeasant-rihanna-bumps-into-legend-paul-mccartney-on-flight%2F21346%2F"><i class="fa fa-google-plus"></i><span>Google Plus</span></a></li><li class="pinterest"> <a href="javascript:void(0);" data-url="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fsunriseread.com%2Fpeasant-rihanna-bumps-into-legend-paul-mccartney-on-flight%2F21346%2F&amp;media=https%3A%2F%2Fi0.wp.com%2Fsunriseread.com%2Fwp-content%2Fuploads%2F2020%2F01%2Frihanna-paul-mccartney.jpg%3Ffit%3D1200%252C791%26amp%3Bssl%3D1&amp;description=%E2%80%98Peasant%E2%80%99+Rihanna+bumps+into+%E2%80%98legend%E2%80%99+Paul+McCartney+on+flight"><i class="fa fa-pinterest"></i><span>Pinterest</span></a></li><li class="linkedin"> <a href="javascript:void(0);" data-url="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fsunriseread.com%2Fpeasant-rihanna-bumps-into-legend-paul-mccartney-on-flight%2F21346%2F&amp;title=%E2%80%98Peasant%E2%80%99+Rihanna+bumps+into+%E2%80%98legend%E2%80%99+Paul+McCartney+on+flight"><i class="fa fa-linkedin"></i><span>LinkedIn</span></a></li></div></ul></div></div><div class="col-lg-10 col-md-10 col-sm-10"><div class="entry-content herald-entry-content"><div class="herald-ad herald-ad-above-single"><center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-9781525442333142"
data-ad-slot="6509887705"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></center></div><div><figure id="attachment_5062395" class="wp-caption alignleft"><img class="wp-image-5062395 size-nypost-inline-default lazyload" alt="Rihanna records running into Paul McCartney on Instagram." width="300" height="463" data- data-/><figcaption class="wp-caption-text"><span>Rihanna information operating into Paul McCartney on her flight.</span><span class="credit">Instagram </span></figcaption></figure><p class="p1">After Rihanna’s fast journey to Italy, the songstress was stunned to seek out icon and former collaborator Paul McCartney on her flight.</p><p>“I’m about to place you on blast, Mr. McCartney. How are you on my flight?” Riri, 31, requested via giggles within the Instagram video, with the previous Beatle responding, “Who is that this filming me?”</p><p>Taking part in alongside, Rihanna added, ”Who is that this peasant recording this legend?”</p><p>The 2 collaborated — together with Kanye West — on Rihanna’s single “FourFiveSeconds,” performing the acoustic observe collectively through the 2015 Grammys.</p><p>Whereas their vacation spot was unclear, upon touchdown the “Man Down” songstress wished her dwelling island, Barbados, a contented birthday. Nov. 30 is widely known because the nation’s Independence Day.</p></p></div><p></p><div class="hatom-extra" style="display:none;visibility:hidden;"><span class="entry-title">‘Peasant’ Rihanna bumps into ‘legend’ Paul McCartney on flight</span> was last modified: <span class="updated"> January 2nd, 2020</span> by <span class="author vcard"><span class="fn">Sam Conley</span></span></div><div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://sunriseread.com/liam-paynes-new-song-both-ways-slammed-as-silly-stereotype-of-bisexual-girls/10780/" target="_blank" rel="nofollow" class="u2ded14cd459c5811095407b1f0322c55"><style>.u2ded14cd459c5811095407b1f0322c55{padding:0;margin:0;padding-top:1em!important;padding-bottom:1em!important;width:100%;display:block;font-weight:700;background-color:#eaeaea;border:0!important;border-left:4px solid #34495E!important;text-decoration:none}.u2ded14cd459c5811095407b1f0322c55:active,.u2ded14cd459c5811095407b1f0322c55:hover{opacity:1;transition:opacity 250ms;webkit-transition:opacity 250ms;text-decoration:none}.u2ded14cd459c5811095407b1f0322c55{transition:background-color 250ms;webkit-transition:background-color 250ms;opacity:1;transition:opacity 250ms;webkit-transition:opacity 250ms}.u2ded14cd459c5811095407b1f0322c55 .ctaText{font-weight:700;color:inherit;text-decoration:none;font-size:16px}.u2ded14cd459c5811095407b1f0322c55 .postTitle{color:#000;text-decoration:underline!important;font-size:16px}.u2ded14cd459c5811095407b1f0322c55:hover .postTitle{text-decoration:underline!important}</style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">READ</span>&nbsp; <span class="postTitle">Liam Payne’s new song Both Ways slammed as ‘silly stereotype of bisexual girls’</span></div></a></div><div class="herald-ad"><center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-9781525442333142"
data-ad-slot="6509887705"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></center></div></div></div><div id="extras" class="col-lg-12 col-md-12 col-sm-12"><div id="related" class="herald-related-wrapper"><div class="herald-mod-wrap"><div class="herald-mod-head "><div class="herald-mod-title"><h4 class="h6 herald-mod-h herald-color">You may also like</h4></div></div></div><div class="herald-related row row-eq-height"><article class="herald-lay-f herald-lay-f1 post-21334 post type-post status-publish format-standard has-post-thumbnail hentry category-general-news"><div class="herald-ovrld"><div class="herald-post-thumbnail"> <a href="https://sunriseread.com/meghan-markle-and-prince-harry-archies-character-is-already-taking-form/21334/" title="Meghan Markle and Prince Harry: Archie’s character is already taking form!"><img width="300" height="200" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?resize=300%2C200&amp;ssl=1" class="attachment-herald-lay-b1 size-herald-lay-b1 wp-post-image" alt="" data-lazy-srcset="https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?resize=414%2C276&amp;ssl=1 414w, https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?resize=470%2C313&amp;ssl=1 470w, https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?resize=130%2C86&amp;ssl=1 130w, https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?resize=187%2C124&amp;ssl=1 187w, https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?zoom=2&amp;resize=300%2C200&amp;ssl=1 600w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /><noscript><img width="300" height="200" src="https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?resize=300%2C200&amp;ssl=1" class="attachment-herald-lay-b1 size-herald-lay-b1 wp-post-image" alt="" srcset="https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?resize=414%2C276&amp;ssl=1 414w, https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?resize=470%2C313&amp;ssl=1 470w, https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?resize=130%2C86&amp;ssl=1 130w, https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?resize=187%2C124&amp;ssl=1 187w, https://i2.wp.com/sunriseread.com/wp-content/uploads/2020/01/a4-e1577990201670.jpg?zoom=2&amp;resize=300%2C200&amp;ssl=1 600w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></div><div class="entry-header"> <span class="meta-category"><a href="https://sunriseread.com/category/general-news/" class="herald-cat-3">General News</a></span><h2 class="entry-title h6"><a href="https://sunriseread.com/meghan-markle-and-prince-harry-archies-character-is-already-taking-form/21334/">Meghan Markle and Prince Harry: Archie’s character is already taking form!</a></h2><div class="entry-meta"><div class="meta-item herald-date"><span class="updated">2nd January 2020</span></div></div></div></div></article><article class="herald-lay-f herald-lay-f1 post-21325 post type-post status-publish format-standard has-post-thumbnail hentry category-general-news"><div class="herald-ovrld"><div class="herald-post-thumbnail"> <a href="https://sunriseread.com/miley-cyrus-divorced-from-liam-hemsworth-she-definitively-turns-the-page-with-this-video/21325/" title="Miley Cyrus divorced from Liam Hemsworth: she definitively turns the page with this video!"><img width="300" height="200" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/a5-1-e1577990365572.jpg?resize=300%2C200&amp;ssl=1" class="attachment-herald-lay-b1 size-herald-lay-b1 wp-post-image" alt="" data-lazy-srcset="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/a5-1-e1577990365572.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/a5-1-e1577990365572.jpg?resize=414%2C276&amp;ssl=1 414w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/a5-1-e1577990365572.jpg?resize=130%2C86&amp;ssl=1 130w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/a5-1-e1577990365572.jpg?resize=187%2C124&amp;ssl=1 187w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/a5-1-e1577990365572.jpg?resize=459%2C304&amp;ssl=1 459w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/a5-1-e1577990365572.jpg?zoom=2&amp;resize=300%2C200&amp;ssl=1 600w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /><noscript><img width="300" height="200" src="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/a5-1-e1577990365572.jpg?resize=300%2C200&amp;ssl=1" class="attachment-herald-lay-b1 size-herald-lay-b1 wp-post-image" alt="" srcset="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/a5-1-e1577990365572.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/a5-1-e1577990365572.jpg?resize=414%2C276&amp;ssl=1 414w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/a5-1-e1577990365572.jpg?resize=130%2C86&amp;ssl=1 130w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/a5-1-e1577990365572.jpg?resize=187%2C124&amp;ssl=1 187w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/a5-1-e1577990365572.jpg?resize=459%2C304&amp;ssl=1 459w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/a5-1-e1577990365572.jpg?zoom=2&amp;resize=300%2C200&amp;ssl=1 600w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></div><div class="entry-header"> <span class="meta-category"><a href="https://sunriseread.com/category/general-news/" class="herald-cat-3">General News</a></span><h2 class="entry-title h6"><a href="https://sunriseread.com/miley-cyrus-divorced-from-liam-hemsworth-she-definitively-turns-the-page-with-this-video/21325/">Miley Cyrus divorced from Liam Hemsworth: she definitively turns the page with this video!</a></h2><div class="entry-meta"><div class="meta-item herald-date"><span class="updated">2nd January 2020</span></div></div></div></div></article><article class="herald-lay-f herald-lay-f1 post-21322 post type-post status-publish format-standard has-post-thumbnail hentry category-general-news"><div class="herald-ovrld"><div class="herald-post-thumbnail"> <a href="https://sunriseread.com/kid-rock-explains-his-problem-with-oprah-after-foul-mouthed-rant/21322/" title="Kid Rock explains his problem with Oprah after foul-mouthed rant"><img width="300" height="200" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=300%2C200&amp;ssl=1" class="attachment-herald-lay-b1 size-herald-lay-b1 wp-post-image" alt="" data-lazy-srcset="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?w=1200&amp;ssl=1 1200w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=1024%2C680&amp;ssl=1 1024w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=768%2C510&amp;ssl=1 768w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=414%2C276&amp;ssl=1 414w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=470%2C313&amp;ssl=1 470w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=640%2C426&amp;ssl=1 640w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=130%2C86&amp;ssl=1 130w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=187%2C124&amp;ssl=1 187w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=990%2C658&amp;ssl=1 990w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /><noscript><img width="300" height="200" src="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=300%2C200&amp;ssl=1" class="attachment-herald-lay-b1 size-herald-lay-b1 wp-post-image" alt="" srcset="https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?w=1200&amp;ssl=1 1200w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=1024%2C680&amp;ssl=1 1024w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=768%2C510&amp;ssl=1 768w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=414%2C276&amp;ssl=1 414w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=470%2C313&amp;ssl=1 470w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=640%2C426&amp;ssl=1 640w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=130%2C86&amp;ssl=1 130w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=187%2C124&amp;ssl=1 187w, https://i0.wp.com/sunriseread.com/wp-content/uploads/2020/01/kid-rock-oprah-winfrey-2.jpg?resize=990%2C658&amp;ssl=1 990w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></div><div class="entry-header"> <span class="meta-category"><a href="https://sunriseread.com/category/general-news/" class="herald-cat-3">General News</a></span><h2 class="entry-title h6"><a href="https://sunriseread.com/kid-rock-explains-his-problem-with-oprah-after-foul-mouthed-rant/21322/">Kid Rock explains his problem with Oprah after foul-mouthed rant</a></h2><div class="entry-meta"><div class="meta-item herald-date"><span class="updated">2nd January 2020</span></div></div></div></div></article></div></div><div id="author" class="herald-vertical-padding"><div class="herald-mod-wrap"><div class="herald-mod-head "><div class="herald-mod-title"><h4 class="h6 herald-mod-h herald-color">About the author</h4></div><div class="herald-mod-actions"><a href="https://sunriseread.com/author/samantha/">View All Posts</a></div></div></div><div class="herald-author row"><div class="herald-author-data col-lg-2 col-md-2 col-sm-2 col-xs-2"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://secure.gravatar.com/avatar/1477b2ca4dfdfa3258752a6afb38c412?s=140&#038;d=mm&#038;r=g" width="140" height="140" alt="Avatar" class="avatar avatar-140 wp-user-avatar wp-user-avatar-140 photo avatar-default" /><noscript><img src="https://secure.gravatar.com/avatar/1477b2ca4dfdfa3258752a6afb38c412?s=140&#038;d=mm&#038;r=g" width="140" height="140" alt="Avatar" class="avatar avatar-140 wp-user-avatar wp-user-avatar-140 photo avatar-default" /></noscript></div><div class="herald-data-content col-lg-10 col-md-10 col-sm-10 col-xs-10"><h4 class="author-title">Sam Conley</h4><p>Sam Conley is new to online journalism but she is keen to learn. She is an MBA from a reputed university. She brings together relevant news pieces from various industries. She loves to share quick news updates. She is always in search of interesting news so that she can share them as well to Sunriseread's readers who could enjoy them with their morning coffee.</p></div></div></div><div id="comments" class="herald-comments"><div class="herald-mod-wrap"><div class="herald-mod-head "><div class="herald-mod-title"><h4 class="h6 herald-mod-h herald-color">Add Comment</h4></div></div></div><div class="herald-gray-area"><span class="herald-fake-button herald-comment-form-open">Click here to post a comment</span></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/peasant-rihanna-bumps-into-legend-paul-mccartney-on-flight/21346/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://sunriseread.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name<span class="required"> *</span></label> <input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p><p class="comment-form-email"><label for="email">Email<span class="required"> *</span></label> <input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p><p class="comment-form-url"><label for="url">Website</label><input id="url" name="url" type="text" value="" size="30" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post comment" /> <input type='hidden' name='comment_post_ID' value='21346' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="4829b584e1" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="213"/></p></form></div></div><div id="single-sticky" class="herald-single-sticky herald-single-wraper hidden-xs hidden-sm"><div class="container"><div class="row"><div class="col-lg-12 col-md-12"><div class="herald-sticky-prev h6"> <a href="https://sunriseread.com/new-hellraiser-trilogy-is-coming-in-2020-heres-everything-we-know/21337/" rel="prev">New Hellraiser Trilogy Is Coming In 2020! Here’s Everything We Know</a></div><div class="herald-sticky-share"> <a href="https://sunriseread.com/peasant-rihanna-bumps-into-legend-paul-mccartney-on-flight/21346/#respond" class="herald-comment-action" >Comment</a><ul class="herald-share"> <span class="herald-share-meta"><i class="fa fa-share-alt"></i>Share This!</span><div class="meta-share-wrapper"><li class="facebook"> <a href="javascript:void(0);" data-url="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fsunriseread.com%2Fpeasant-rihanna-bumps-into-legend-paul-mccartney-on-flight%2F21346%2F&amp;t=%E2%80%98Peasant%E2%80%99+Rihanna+bumps+into+%E2%80%98legend%E2%80%99+Paul+McCartney+on+flight"><i class="fa fa-facebook"></i><span>Facebook</span></a></li><li class="twitter"> <a href="javascript:void(0);" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fsunriseread.com%2Fpeasant-rihanna-bumps-into-legend-paul-mccartney-on-flight%2F21346%2F&amp;text=%E2%80%98Peasant%E2%80%99+Rihanna+bumps+into+%E2%80%98legend%E2%80%99+Paul+McCartney+on+flight"><i class="fa fa-twitter"></i><span>Twitter</span></a></li><li class="gplus"> <a href="javascript:void(0);" data-url="https://plus.google.com/share?url=https%3A%2F%2Fsunriseread.com%2Fpeasant-rihanna-bumps-into-legend-paul-mccartney-on-flight%2F21346%2F"><i class="fa fa-google-plus"></i><span>Google Plus</span></a></li><li class="pinterest"> <a href="javascript:void(0);" data-url="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fsunriseread.com%2Fpeasant-rihanna-bumps-into-legend-paul-mccartney-on-flight%2F21346%2F&amp;media=https%3A%2F%2Fi0.wp.com%2Fsunriseread.com%2Fwp-content%2Fuploads%2F2020%2F01%2Frihanna-paul-mccartney.jpg%3Ffit%3D1200%252C791%26amp%3Bssl%3D1&amp;description=%E2%80%98Peasant%E2%80%99+Rihanna+bumps+into+%E2%80%98legend%E2%80%99+Paul+McCartney+on+flight"><i class="fa fa-pinterest"></i><span>Pinterest</span></a></li><li class="linkedin"> <a href="javascript:void(0);" data-url="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fsunriseread.com%2Fpeasant-rihanna-bumps-into-legend-paul-mccartney-on-flight%2F21346%2F&amp;title=%E2%80%98Peasant%E2%80%99+Rihanna+bumps+into+%E2%80%98legend%E2%80%99+Paul+McCartney+on+flight"><i class="fa fa-linkedin"></i><span>LinkedIn</span></a></li></div></ul></div></div></div></div></div></div></div></div><div class="herald-sidebar col-lg-3 col-md-3 herald-sidebar-right"><div id="text-2" class="widget widget_text"><h4 class="widget-title h6"><span>Quick Contact!</span></h4><div class="textwidget"><p>To get in touch with <strong>Sunriseread</strong> or to tell us about a Story or Press Release, just send an email to <a href="/cdn-cgi/l/email-protection#a3cfcacdc7c2cbccd3c8cacdd092919b83e383c4cec2cacf8dc0cccea9">lindahopkins128 @ gmail.com<br /> </a>. And, we will get back to you shortly.</p></div></div><div id="text-3" class="widget widget_text"><div class="textwidget"><p><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <br /> <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-9781525442333142"
data-ad-slot="2036952932"
data-ad-format="auto"
data-full-width-responsive="true"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></div><div id="search-2" class="widget widget_search"><form class="herald-search-form" action="https://sunriseread.com/" method="get"> <input name="s" class="herald-search-input" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="herald-search-submit"></button></form></div><div id="recent-posts-2" class="widget widget_recent_entries"><h4 class="widget-title h6"><span>Recent News</span></h4><ul><li> <a href="https://sunriseread.com/peasant-rihanna-bumps-into-legend-paul-mccartney-on-flight/21346/" aria-current="page">‘Peasant’ Rihanna bumps into ‘legend’ Paul McCartney on flight</a></li><li> <a href="https://sunriseread.com/what-to-watch-chance-the-rapper-on-snl-christmas-movies-and-more/21343/">What to Watch: Chance the Rapper on SNL, Christmas (!?) Movies and More</a></li><li> <a href="https://sunriseread.com/link-tank-the-wildest-space-discoveries-of-2019/21340/">Link Tank: The Wildest Space Discoveries of 2019</a></li><li> <a href="https://sunriseread.com/new-hellraiser-trilogy-is-coming-in-2020-heres-everything-we-know/21337/">New Hellraiser Trilogy Is Coming In 2020! Here’s Everything We Know</a></li><li> <a href="https://sunriseread.com/meghan-markle-and-prince-harry-archies-character-is-already-taking-form/21334/">Meghan Markle and Prince Harry: Archie’s character is already taking form!</a></li><li> <a href="https://sunriseread.com/performer-of-the-week-lizzy-caplan/21331/">Performer of the Week: Lizzy Caplan</a></li><li> <a href="https://sunriseread.com/rankings-hawaii-five-0-ties-season-excessive-magnum-p-i-also-rises/21328/">Rankings: Hawaii Five-0 Ties Season Excessive, Magnum P.I. Also Rises</a></li><li> <a href="https://sunriseread.com/miley-cyrus-divorced-from-liam-hemsworth-she-definitively-turns-the-page-with-this-video/21325/">Miley Cyrus divorced from Liam Hemsworth: she definitively turns the page with this video!</a></li><li> <a href="https://sunriseread.com/kid-rock-explains-his-problem-with-oprah-after-foul-mouthed-rant/21322/">Kid Rock explains his problem with Oprah after foul-mouthed rant</a></li><li> <a href="https://sunriseread.com/star-wars-9-unanswered-questions-in-the-mandalorian/21319/">Star Wars: 9 Unanswered Questions in The Mandalorian</a></li><li> <a href="https://sunriseread.com/rachel-maddow-confronts-nbc-news-about-handling-of-sexual-misconduct-allegations-ronan-farrow-reporting/21316/">Rachel Maddow Confronts NBC News About Handling of Sexual Misconduct Allegations, Ronan Farrow Reporting</a></li><li> <a href="https://sunriseread.com/justin-bieber-and-hailey-baldwin-pose-in-swimsuits-for-the-new-12-months/21313/">Justin Bieber and Hailey Baldwin pose in swimsuits for the new 12 months!</a></li><li> <a href="https://sunriseread.com/grace-and-frankie-enter-the-shark-tank-in-season-6-trailer-watch/21310/">Grace and Frankie Enter the Shark Tank in Season 6 Trailer — WATCH</a></li><li> <a href="https://sunriseread.com/leonardo-dicaprio-hits-back-against-accusation-of-setting-amazon-fires/21307/">Leonardo DiCaprio hits back against accusation of setting Amazon fires</a></li><li> <a href="https://sunriseread.com/bella-hadid-celebrates-the-new-year-in-very-sexy-lingerie-pictures/21304/">Bella Hadid celebrates the new year in very sexy lingerie! (PICTURES)</a></li></ul></div><div id="categories-2" class="widget widget_categories"><h4 class="widget-title h6"><span>Categories</span></h4><ul><li class="cat-item cat-item-4"><a href="https://sunriseread.com/category/business/"><span class="category-text">Business</span></a></li><li class="cat-item cat-item-3"><a href="https://sunriseread.com/category/general-news/"><span class="category-text">General News</span></a></li><li class="cat-item cat-item-2"><a href="https://sunriseread.com/category/technology/"><span class="category-text">Technology</span></a></li><li class="cat-item cat-item-95"><a href="https://sunriseread.com/category/usa/"><span class="category-text">USA</span></a></li></ul></div></div></div></article></div></div><footer id="footer" class="herald-site-footer herald-slide"><div class="footer-widgets container"><div class="row"><div class="col-lg-3 col-md-3 col-sm-3"></div><div class="col-lg-3 col-md-3 col-sm-3"></div><div class="col-lg-3 col-md-3 col-sm-3"></div><div class="col-lg-3 col-md-3 col-sm-3"></div></div></div><div class="footer-bottom"><div class="container"><div class="row"><div class="col-lg-12"><div class="hel-l herald-go-hor"><div class="herald-copyright">Copyright &copy; 2019.</div></div><div class="hel-r herald-go-hor"></div></div></div></div></div></footer> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202001' defer></script> <script type='text/javascript' src='https://stats.wp.com/e-202001.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.0',blog:'165866292',post:'21346',tz:'-5',srv:'sunriseread.com'} ]);
	_stq.push([ 'clickTrackerInit', '165866292', '21346' ]);</script> <script>(function(w, d){
	var b = d.getElementsByTagName("body")[0];
	var s = d.createElement("script"); s.async = true;
	var v = !("IntersectionObserver" in w) ? "8.12" : "10.12";
	s.src = "https://sunriseread.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-" + v + ".min.js";
	w.lazyLoadOptions = {
		elements_selector: "img, iframe",
		data_src: "lazy-src",
		data_srcset: "lazy-srcset",
		data_sizes: "lazy-sizes",
		skip_invisible: false,
		class_loading: "lazyloading",
		class_loaded: "lazyloaded",
		threshold: 300,
		callback_load: function(element) {
			if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
				if (element.classList.contains("lazyloaded") ) {
					if (typeof window.jQuery != "undefined") {
						if (jQuery.fn.fitVids) {
							jQuery(element).parent().fitVids();
						}
					}
				}
			}
		}
	}; // Your options here. See "recipes" for more information about async.
	b.appendChild(s);
}(window, document));

// Listen to the Initialized event
window.addEventListener('LazyLoad::Initialized', function (e) {
    // Get the instance and puts it in the lazyLoadInstance variable
	var lazyLoadInstance = e.detail.instance;

	var observer = new MutationObserver(function(mutations) {
		mutations.forEach(function(mutation) {
			lazyLoadInstance.update();
		} );
	} );
	
	var b      = document.getElementsByTagName("body")[0];
	var config = { childList: true, subtree: true };
	
	observer.observe(b, config);
}, false);</script> <script src="https://sunriseread.com/wp-content/cache/min/1/aa199e9dceb7d6aa4ef7e4342cb01ad7.js" data-minify="1" defer></script><noscript><link rel="stylesheet" href="https://sunriseread.com/wp-content/cache/min/1/8bc1eee8698f291a7c408e5d6b7a0be9.css" data-minify="1" /></noscript><noscript><link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='herald-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%7CLato%3A400%2C700&#038;subset=latin%2Clatin-ext&#038;ver=1.5.2' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.0/css/jetpack.css' type='text/css' media='all' /></noscript></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1578012416 -->